请选择 进入手机版 | 继续访问电脑版

迪普科技技术论坛

 找回密码
 立即注册

关注我们 扫描二维码关注迪普官方微信 迪普新浪微博  迪普官网

最新动态 新闻动态  安全研究 最佳实践  加入迪普

DP 自安全园区网解决方案 DP 自安全分支机构解决方案 DP 自安全物联感知网解决方案

查看: 20757|回复: 33

MP-BGP MPLS VPN配置步骤

[复制链接]

20

主题

62

帖子

420

积分

中级会员

Rank: 3Rank: 3

积分
420
发表于 2014-8-4 17:08:31 | 显示全部楼层 |阅读模式
本帖最后由 G00972 于 2014-8-5 14:47 编辑


拓扑图:PC1——DUT(两台19K-VSM)——SW3——SW4——PC2
(备注:DUT、SW3、SW4启用IGP内部路由网关ospf路由协议,宣告互联网段及loopback接口网段实现PE之间32位loopback地址可达;
DUT和SW4作为PE设备,DUT和SW4建立IBGP邻居关系;DUT、SW3、SW4之间启用多标签交换协议即MPLS标签交换协议,vpn实例、mp-bgp。)
BGP MPLS VPN配置思路:
游客,如果您要查看本帖隐藏内容请回复
议时前提,保证loopback口路由可达。)[/hide]
1、配置公网隧道
[DUT]mpls
[DUT-MPLS]ldp      
[DUT-MPLS-LDP]redistribute connected
[DUT-MPLS-LDP]lsr-id 192.168.1.2
[DUT-MPLS-LDP]network vlan-if30
[DUT-MPLS-LDP]exit
[DUT-MPLS]
[DUT-MPLS]
[DUT-MPLS]
[sw4]mpls
[sw4-MPLS]ldp
[sw4-MPLS-LDP]redistribute connected
[sw4-MPLS-LDP]lsr-id 192.168.1.4
[sw4-MPLS-LDP]network vlan-if40
[sw4-MPLS-LDP]exit
[sw4-MPLS]

[sw3]mpls
[sw3-MPLS]ldp
[sw3-MPLS-LDP]lsr-id 192.168.1.3
[sw3-MPLS-LDP]redistribute connected
[sw3-MPLS-LDP]network vlan-if30
[sw3-MPLS-LDP]network vlan-if40
[sw3-MPLS-LDP]exit
[sw3-MPLS]exit
[sw3]
查看:show mpls ldp binding
2、配置本地VPN
DUT配置:
[DUT]ovc enable
[DUT]ovc create 19k
[DUT]ovc 19k
[DUT-ovc]rd 100:1 (route-distinguisher 路由区分自治系统号)
[DUT-ovc]router-target import 1000:1
[DUT-ovc]router-target export 2000:1(扩展属性rt路由目标)
[DUT-ovc]exit
[DUT]int vlan-if20
[DUT-vlan-if20]ovc bind 19k(私网接口下绑定vpn实例)
Interface vlan-if20 IP address  192.168.20.1/24 IPV6 address 240e:b5:8001::2:a0a:2001/120 removed due to enabling OVC 19k
[DUT-vlan-if20]exit
[DUT]exit
<DUT>switchtoovc 19k
Now change to new ovc: 19k.
<DPTECH-19k>conf-mode
[DUT-19k]int vlan-if20
[DUT-vlan-if20-19k]ip address 192.168.20.1/24
[DUT-vlan-if20-19k]exit
<DUT-19k>exit
sw4配置:
[sw4]ovc enable
[sw4]ovc create sw4
[sw4]ovc sw4
[sw4-ovc]rd 200:1
[sw4-ovc]router-target import 2000:1
[sw4-ovc]router-target export 1000:1
[sw4-ovc]exit
[sw4]vlan 50
[sw4-vlan50]port gige0_18
[sw4-vlan50]exit
[sw4]
[sw4]int vlan-if50
[sw4-vlan-if50]ovc bind sw4
Interface vlan-if50 IP address  192.168.50.1/24 removed due to enabling OVC sw4
[sw4-vlan-if50]
[sw4-vlan-if50]exit
[sw4]exit
<sw4>switchtoovc sw4
Now change to new ovc: sw4.
<sw4-sw4>conf-mode
[sw4-sw4]int vlan-if50
[sw4-vlan-if50-sw4]ip address 192.168.50.1/24
<sw4-sw4>exit
<sw4>

3、配置MP-BGP步骤(备注:MP-BGP多协议BGP,配置mp-bgp路由协议的方法是,进入router bgp as号 。)
DUT配置:
[DUT]router bgp 1000(普通bgp配置)
[DUT-bgp]neighbor 192.168.1.4 remote-as 1000
[DUT-bgp]neighbor 192.168.1.4 update-source loopback1 (指定loopback口建立BGP邻居)
[DUT-bgp]address-family vpnv4 unicast (使能对等体交换bgp-vpnv4 路由信息,进入bgp vpnv4地址族使能bgp邻居。——多协议bgp配置mp-bgp)
[DUT-bgp-vpnv4]neighbor 192.168.1.4 activate (激活BGP邻居)
[DUT-bgp-vpnv4]neighbor 192.168.1.4 send-community both (使能两项扩展属性)
[DUT-bgp-vpnv4]exit
[DUT-bgp]exit
[DUT]router bgp  1000
[DUT-bgp]address-family ipv4 ovc 19k
DUT(config-router-af-ovc)# network 192.168.20.0/24 (VPN实例中宣告网段)
DUT(config-router-af-ovc)# exit
[DUT-bgp]
[DUT-bgp]exit
<DUT>clear ip bgp *
<DUT>show ip bgp vpnv4 all summary
BGP router identifier 192.168.1.2, local AS number 1000
RIB entries 3, using 192 bytes of memory
Peers 1, using 3820 bytes of memory
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd  Vrf_id
192.168.1.4     4  1000      15      16        0    0    0 00:08:41        1           0
Total number of neighbors 1
<DUT>show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
       I - ISIS, B - BGP, > - selected route, * - FIB route, G - GUARD
C>* 192.168.1.2/32 fmap : 0x1 is directly connected, loopback1 weight 0
O>* 192.168.1.3/32 [110/20] fmap : 0x1 via 192.168.30.2, instance 1, 00:40:15
O>* 192.168.1.4/32 [110/30] fmap : 0x1 via 192.168.30.2, instance 1, 00:34:52
C>* 192.168.30.0/24 fmap : 0x1 is directly connected, vlan-if30 weight 0
O>* 192.168.40.0/24 [110/20] fmap : 0x1 via 192.168.30.2, instance 1, 00:35:09
<DUT>
<DUT>switchtoovc 19k
Now change to new ovc: 19k.
<DUT-19k>show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
       I - ISIS, B - BGP, > - selected route, * - FIB route, G - GUARD
C>* 127.1.0.0/16 fmap : 0x1 is directly connected, ieth0_2.1 weight 0
C>* 127.3.0.0/16 fmap : 0x1 is directly connected, veth0_63.1 weight 0
C>* 192.168.20.0/24 fmap : 0x1 is directly connected, vlan-if20 weight 0
B>* 192.168.50.0/24 [200/1] fmap : 0x1 is directly connected, Null0, bh, 00:00:30
SW4配置:
[sw4]router bgp 1000
[sw4-bgp]neighbor 192.168.1.2 remote-as 1000
[sw4-bgp]neighbor 192.168.1.2 update-source loopback1
[sw4-bgp]address-family vpnv4 unicast
[sw4-bgp-vpnv4]neighbor 192.168.1.2 activate
[sw4-bgp-vpnv4]neighbor 192.168.1.2 send-community both
[sw4-bgp-vpnv4]exit
[sw4-bgp]exit
[sw4]exit
<sw4>conf-mode
[sw4]router bgp 1000
[sw4-bgp]
[sw4-bgp]address-family ipv4 ovc sw4
sw4(config-router-af-ovc)# network 192.168.50.0/24
sw4(config-router-af-ovc)# exit
[sw4-bgp]
[sw4-bgp]exit
[sw4]exit
<sw4>show ip bgp vpnv4 all summary
BGP router identifier 192.168.1.4, local AS number 1000
RIB entries 1, using 64 bytes of memory
Peers 1, using 3820 bytes of memory
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd  Vrf_id
192.168.1.2     4  1000      18      24        0    0    0 00:00:09        1           0
Total number of neighbors 1
<sw4-sw4>show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
       I - ISIS, B - BGP, > - selected route, * - FIB route, G - GUARD
B>* 192.168.20.0/24 [200/1] fmap : 0x1 is directly connected, Null0, bh, 00:00:35
C>* 192.168.50.0/24 fmap : 0x1 is directly connected, vlan-if50 weight 0
<sw4-sw4>

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

40

主题

78

帖子

566

积分

高级会员

Rank: 4

积分
566
发表于 2014-8-5 15:00:39 | 显示全部楼层
受益匪浅啊
回复 支持 反对

使用道具 举报

6

主题

10

帖子

90

积分

注册会员

Rank: 2

积分
90
QQ
发表于 2014-8-5 15:50:35 | 显示全部楼层
好好学习一下!
回复 支持 反对

使用道具 举报

57

主题

72

帖子

992

积分

高级会员

Rank: 4

积分
992
发表于 2014-8-5 20:36:08 | 显示全部楼层
这个不错
回复

使用道具 举报

18

主题

23

帖子

187

积分

注册会员

Rank: 2

积分
187
发表于 2014-8-6 20:57:35 | 显示全部楼层
有用,以后遇到了会有大用的啊!
回复 支持 反对

使用道具 举报

82

主题

130

帖子

1057

积分

金牌会员

Rank: 6Rank: 6

积分
1057
发表于 2014-8-7 08:20:01 | 显示全部楼层
赞一个,棒棒的
回复 支持 反对

使用道具 举报

0

主题

5

帖子

27

积分

新手上路

Rank: 1

积分
27
发表于 2014-10-15 13:14:53 | 显示全部楼层
求观看,求学习
回复 支持 反对

使用道具 举报

0

主题

1

帖子

19

积分

新手上路

Rank: 1

积分
19
发表于 2014-12-16 09:18:51 | 显示全部楼层
谢谢楼主,非常棒
回复 支持 反对

使用道具 举报

21

主题

27

帖子

313

积分

中级会员

Rank: 3Rank: 3

积分
313
发表于 2014-12-29 11:13:46 | 显示全部楼层
vpn使用ovc配置,不便于日常维护和故障定位,建议采用vrf实现vpn功能:
vrf enable
vrf create vpn1
vrf create vpn2
回复 支持 反对

使用道具 举报

28

主题

108

帖子

4831

积分

论坛元老

Rank: 8Rank: 8

积分
4831
发表于 2014-12-29 21:17:37 | 显示全部楼层
111111111111
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|迪普科技 ( 浙ICP备09001402号-2 )

GMT+8, 2021-9-22 23:12 , Processed in 0.182134 second(s), 23 queries .

Powered by Discuz! X3.1

© 2001-2014 Comsenz Inc.

快速回复 返回顶部 返回列表